Błąd przy próbie uruchomienia SuperPi 32-bit na serwerze CentOS 6 64-bit

Przy próbie uruchomienia SuperPi 32-bit na serwerze z systemem operacyjnym CentOS 6 64-bit,
może pojawić się czasem problem, sygnalizowany komunikatem:

./super_pi: ./pi: /lib/ld-linux.so.2: bad ELF interpreter: Nie ma takiego pliku ani katalogu

Problemem jest brak wsparcia bibliotek 32-bitowych w systemie 64-bitowym. Wystarczy zainstalować pakiet glibc dla 32-bitowych systemów i problem rozwiązany:

[sudo] yum install glibc.i686

One thought on “Błąd przy próbie uruchomienia SuperPi 32-bit na serwerze CentOS 6 64-bit

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *